
SURA B
OOKSgFâ - I

I.		 Äf¢ rÇahd Éilia¤ nj®ªbjL¤J vGJf : 	

		�    [75 × 1 = 75]
1.	 °lh® ng°Ìš Ñœ¡f©lt‰¿š vJ xU tif 

ÉdtyhF« ?

	 m) 	 m£ltid	 M)	 got«

	 ï)	 m¿¡if	  <)	 tof£o

2.	 xnu xU m£ltizia¡ bfh©L mik¡f¥g£l 

juîjs« : 

	 m)	 x‰iw¡ nfh¥ò juîjs«

	 M)	 cwî Ãiy juîjs«

	 ï)	 tiyaik¥ò juîjs«

	  <)	 goÃiy juîjs«

3.	 C++ - š v¤jid mQ»ašò tiuaW¥ãfis¡ 

bfh©lJ ?

	 m)	 2 (ïu©L) 		  M)	 3 (_‹W)

 	 ï)	 4 (eh‹F)	  	 <)	 5 (IªJ)

4.	 xU kU¤Jt nehŒ MŒÉ‹ Koîfis 

És¡F»‹w xUÃiyahd r£ló®tkhd 

Mtz« :

	 m)	 bjhiy kU¤Jt«

	 M)	 juî nkyh©ik

	 ï)	 kU¤Jt bga®¥ghtz«

	  <)	 juth¡f«

5.	 bfhlhÃiyahf °lh® iu£l® Mtz§fŸ ïªj 

ïilbtËÆš ïU¡F« :

	 m)	 1 tÇ (Single)	
	 M)  	 1.5 tÇ

	 ï)   	2 tÇ (Double ) 	
	  <)	 Fiwªjg£r« (Atleast )
6.	 °lh® fhš¡»š njâia vªj tÇir¥go 

bfhL¡f nt©L« ? 

	 m)	 DD/MM/YY     	

	 M)	 MM/DD/YY
	 ï)   YY/MM/DD
	 <)	 DD/YY/MM

7.	 °lh® ï«¥uÌš všyh ášYfËY« tu nt©oa 

ã‹dÂ¢ brŒâfis nr®¡f vJ cjî»wJ? 

	 m)	 Slide Transition
	 M)	 Layouts
	 ï)	 Master page
	 <)	 Custom Animation
8.	 juîjs nkyh©ik mik¥ãš (DBMS) 

bra‰ghLfis v¤jid bghJ¥ ãÇîfshf¥ 

ãÇ¡fyh« ? 

	 m)	 eh‹F 	 M)	 IªJ

	 ï)	 ïu©L	 <)	 _‹W

9.	 AVI got« vªj ÃWtd¤jhš cUtik¡f¥g£lJ? 

	 m)	 IBM	 M)	 Microsoft
	 ï)	 Apple	  <)	 Macromedia
10.	 K j ‹ K j y h f  f Â ¥ b g h ¿  e ‹ b d ¿ ¡ 

nfh£ghLfis F¿¥ã£lt® : 

	 m)	 Ç¡ kh°á£o 	

	 M)	  lh‹gh®¡f®

	 ï)	 n#®‹ °£bu›°£u¥

 	  <)	 eh®bg®£ btŒd®

11.	 °lh® iu£lÇ‹ m£ltidÆš nj®î brŒa¥g£l 

beLtÇirfis Ú¡f ga‹gL« f£lis :  

	 m)	 Table → Delete → Rows
 	 M)	 Table → Delete → Columns	
	 ï)	 Table → Delete → Table
 	  <)	 Columns → Delete 
12.	 gad® tiuaW¤j M¡» ïšyhj nghJ Ãuš 

bga®¥ã jhdhfnt cUth¡F« M¡»Æ‹ 

bga® :

	 m)	 jhdikî M¡»

 	 M)	 efš M¡»

	 ï)	 msòU V‰F« M¡»

 	  <)	 void M¡»

13.	 C++ -š vªj kâ¥igí« âU¥ã mD¥ghj 

bra‰TW v›thW m¿É¡f¥gL»wJ?

	 m)	 main	 	 	 M)	 friend
	 ï)	 void	 	 	 <)	 inline
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14. 	 �xU ïd¡FGÉ‹ ga‹ghL Koî¡F 

tU«nghJ jhdhfnt ïa¡f¥gL« áw¥ò 

bra‰TW :

	 m) 	 M¡»	 M)	 mÊ¥ã

	 ï) 	 inline 	 <)	 void
15.	 GIF Kiw v¤jid f©Â t©z¤j£L 

mik¥ã‰FŸ ml§»aJ ?

	 m)	 16	 M)	 32

	 ï)	 64	 <)	 8

16.	 C++ -š mÂÆ‹ ÑbHh£L v¥nghJ« ïâÈUªJ 

bjhl§F« :

	 m)	 1			   M)	 –1
	 ï)	 2			   <)	 0
17.	 C++ - š vJ gÂÄF¡f¥gl KoahJ?

	 m)	 M¡»	 M)	 bra‰TW

	 ï)	 bra‰F¿	 <)	 mÊ¥ã

18.	 ÃuÈ‹ xU gFâÆÈUªJ ï‹bdhU gFâ¡F 

jhîtj‰F¡ fhuzkhd Ãuš T‰WfŸ v‹gJ: 

	 m)	 f£L¥gh£L¡ f£lik¥òfŸ

	 M)	 kâ¥ãU¤J f£lik¥òfŸ

	 ï)	 cŸç£L f£lik¥òfŸ

	 <)	 btËp£L¡ f£lik¥òfŸ

19.	 C++ - š kuòÇk« bg‰w ïd¡FG¡fË‹ 

tÇirÆš ïa¡f¥gLtJ ? 

	 m)	 mÊ¥ã			 
	 M)	 cW¥ò bra‰TW

	 ï)	 kh¿fŸ

	 <)	 M¡»

20.	 °lh® fhš¡»š cŸs ïy¡fz¥go thŒghLfŸ 

vªj F¿íl‹ bjhl§f nt©L« ?

	 m)	 *	 M)	 =
	 ï)	 &	 <)	 !
21.	 C++ -š rukâ¥ã‹ m§fkhf ïilbtËfisí«, 

vL¤J¡ bfhŸs nt©LbkÅš ga‹gL¤j 

nt©oa bra‰TW.

	 m)	 scanf()	 M)	 cout()
	 ï)	 cin()	 <)	 gets()
22.	 ã‹tU« vªj bkhÊ Äf vËa KiwÆš juî¤ 

js§fSl‹ bjhl®ò bfh©L brašgl 

ga‹gL»wJ ? 

	 m)	 C++	 M)	 C
	 ï)	 SQL	 <)	 DBMS
23.	 å£oÈUªjgona k¡fŸ ïiza¤â‹ tÊahf 

t§» nritfis Efu thŒ¥gË¥gJ vJ ? 

	 m)	 e-mail	 M)	 e-shopping
	 ï)	 e-banking	 <)	 e-learning

24.	 °lh® iu£lÇš nj®ªbjL¤j ciuia 

ika ïirî brŒtj‰F ga‹gL¤j¥gL« 

Éir¥gyif FW¡F tÊ ahJ ? 

	 m)	 Ctrl + J	 M)	 Ctrl + R
	 ï)	 Ctrl + L	 <)	 Ctrl + E
25.	 bt›ntW juî¤js§fË‹ ïu©L¡F nk‰g£l 

m£ltizfËÈUªJ juîfis x‹W nr®¡F« 

bra‰gh£il v›thW miH¡»‹nwh« ? 

	 m)	 njlš 	 M)	 tÇirah¡f«

	 ï)	 tof£lš	 <)	 nr®¤jš

26.	 SQL-‹ ÉÇth¡f« :

	 m)	 Structured Query Language
	 M)	 Sorted Question Language
	 ï)	 Sorter Query Language
	 <)	 Structured Question Language
27.	 ciu Mtz¤âš calc cell tÇir brUf Paste 

special ciuahlš bg£oÆš vªj nj®it nj®î 

brŒa nt©L« ?

	 m)	 Paste 			   M)	 DDE Link
	 ï)	 DLE Link 			  <)	 Link
28.	 C++ bkhÊÆš rhjhuz kâ¥ãU¤J bra‰F¿ : 

	 m)	 = =	 M)	 &
	 ï)	 =	 <)	 +
29.	 cin v‹D« bghUŸ g‰¿a m¿É¥òfŸ vªj 

jiy¥ò¡ nfh¥ãš ju¥g£LŸsJ ? 

	 m)	 conio.h	 M)	 stdio.h
	 ï)	 ostream.h			   <)	 istream.h
30.	 °lh® fhš¡»š ã‹tUtdt‰¿š vJ 

gh®itÆL ïa¡»?

	 m)	 < (less than)	 M)	 & (And)
	 ï) 	 + (Plus)	 <) 	 : (colon)
31.	 °lh® iu£lÇš, m£ltizÆš bfhlh 

Ãiyahf x›bthU á‰wiuí« ã‹tU« vij¡ 

bfh©oU¡F« ?

	 m)	 všiy (Border) 	
	 M)	 tÇir (Row)
	 ï)	 beLtÇir (Column) 
	 <)	 bga® (Name)
32.	 bghJthd g©ãašò bfh©l cU¥bghUŸfË‹ 

th®¥òU :

	 m)	 ïd¡FG	 M)	 bghUŸ

	 ï)	 tÊKiwfŸ	 <)	 g©òfŸ

33.	 C++ - š bkhÊÆš, K‹braÈ be¿íW¤J« vªj 

F¿íl‹ bjhl§F« ? 

 	 m)	 %	 M)	 #
	 ï) 	 >>	 <) 	 <<
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34.	 °lh® fhš¡»š ã‹tU« vªj F¿pL jÅ¤j 

(Absolute) E©ziw KftÇia F¿¡f 

cjî»wJ ? 

	 m)	 !  	 M)	 *
	 ï)	 &	 <)	 $
35.	 ã‹tU« vªj kh¿fŸ mit m¿É¡f¥g£LŸs 

f £ l i s ¤  b j h F â ¡ F  b t Ë n a 

m¿a¥gLtâšiy ?

	 m)	 cŸsik	 M)	 bra‰TW

	 ï)	 nfh¥ò	 <)	 ïd¡FG

36.	 C++ š ã‹tU« vªj ÉLgL tÇiria 

»ilk£l j¤jY¡F ga‹gL¤j nt©L« ? 

	 m)	 \b	 M)	 \t
	 ï)	 \v	 <)	 \n
37.	 ãw ïd¡FG¡fis jUÉ¥gj‰fhf k£Lnk 

ga‹gL« ïd¡FG : 

	 m)	 fU¤âaš	 M)	 mo¥gil

	 ï)	 mÊ¥ã	 <)	 M¡»

38.	 ntWg£l brŒâfS¡F khWg£L brašgL« xU 

bghUË‹ âw‹ v‹gJ : 

	 m)	 kuòÇk«	 M)	 ïd¡FG

	 ï)	 gšYUth¡f«	 <)	 bghUŸ

39.	 ïiza¤â‹ tÊna fšÉ¡ f‰W¥ g£l§fS«, 

rh‹¿jœfS« bgU« KiwÆ‹ bga® vJ ?

	 m)	 Ä‹ - murh©ik

	 M)	 Ä‹ - f‰wš

	 ï)	 Ä‹ - t§»¢nrit

	 <)	 Ä‹ - m£ltiz¢ braÈ

40.	 °lh® iu£lÇš brUF« òŸËia tÇÆ‹ ïWâ‰F 

ef®¤j vªj rhÉia mG¤j nt©L« ? 

	 m)	 End	  		  M)	 Shift + End
	 ï)	 Ctrl + End			   <)	 Home
41.	 C++ -š  Switch T‰iw É£L btËnaw 

bjhFâÆ‹ ïWâÆš vªj¡ f£lisia 

ga‹gL¤j nt©L« ?

	 m)	 Continue		   	 M)	 for
	 ï)	 break			   <)	 do.. while
42.	 °lh® fhš¡»š vªj f£lis¡ bfh©L 

nj®ªbjL¤j E©ziwfËš juî tÇirfis 

cUth¡fyh« ? 

	 m)	 Series	 M)	 Print range
	 ï)	 Fill			   <)	 Insert
43.	 C++ bkhÊÆš miH¥ò¡ T‰¿š F¿¥ãl¥gL« 

msòU¡fŸ ï›thW miH¡f¥gL»‹wd ? 

	 m)	 Kiwahd	 	 	 M)	 bkŒahd

	 ï)	 F¿¥ò	 <)	 nghÈ

44.	 °lh® iu£lÇš x›bthU g¡f§fËY« g¡f 

v©fŸ òF¤j ga‹gL¤j nt©oa f£lis 

vJ ?

	 m)	 Insert→ page numbers
 	 M)	 Tools → page numbers
	 ï)	 Insert → Fields → page number
 	  <)	 Tools → Fields
45.	 C++ -š vªj ïdkh¿fŸ mit m¿É¡f¥gL« 

nghnj 0 (ó{Ía«) v‹w bjhl¡f kâ¥ig 

ïU¤â¡ bfhŸ»wJ ? 

	 m)	 auto, static
 	 M)	 Static, extern
	 ï)	 register, extern
 	  <)	 static, register
46.	 °lh® ng°Ìš xU m£ltizÆš cŸs 

gâîfŸ x›bth‹iwí« milahs« fh£ltšy 

jÅ¤j‹ik thŒªj xU òy« vJ ? 

	 m)	 Kj‹ik âwînfhš

	 M)	 gâî R£o

	 ï)	 ïu©lh« Ãiy âwînfhš

	 <)	 E©ziw R£o

47.	 ITES-‹ ÉÇth¡f« :

	 m)	 IT Economic Services
 	 M)	IT Educational Services
	 ï)	 IT Enabled Services
	 <)	 IT Entertainment Services
48.	 xU bghUŸ neh¡F Ãuyh¡f¤â‹ r¡â thŒªj 

g©ò TW :

	 m)	 ciw bghâah¡f«	  M)	 ïd¡FG

	 ï)	 kuòÇk«	 <)	 juî kiw¥ò

49.	 C + +  - š  Ñ œ ¡ f © l t ‰ W Ÿ  b r a ‰ T W 

gÂÄF¥ãš vJ xU Kiwahd bra‰TW 

K‹toî »ilahJ ?

	 m)	 void fun (int x); 
		  void fun (int y);
 	 M)	 void fun (int x, int y); 
		  void fun (int x, float y); 
	 ï)	 int fun (int y);
		  void fun (float x);
	 <)	 void fun (char x); 
		  void fun (char x, int y);
50.	 1 + pow (3, 2) - ‹ kâ¥ò :

	 m)	 7		  	 M)	 6

	 ï)	 13	 	 	 <)	 10
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51.	 C++  bkhÊÆš xnu juÉd¤ij nr®ªj 

kh¿fË‹ âu£L :

	 m)	 bra‰TW	 M)	 mÂ

	 ï)	 R£L	 <)	 ïd¡FG

52.	 bghUS¡F Ãidtf¤âš ïl« xJ¡f 

ga‹gLtJ : 

	 m)	 M¡»	 M)	 mÊ¥ã

	 ï)	 ïd¡FG	 <)	 rh‹WU

53.	 C++ -š cW¥ò¢ bra‰TWfis ï›thW 

Twyh«? 

	 m)	 g©ò¡ TWfŸ	 M)	 ïd¡FG

	 ï)	 tÊKiwfŸ	 <)	 M¡»fŸ

54.	 gÂÄF¤j bra‰TWfË‹ vªj braYUòfis 

msòU¡fË‹ g£oaÈš xU gFâahf C++ 
Ãuš bga®¥ã fUâ¡ bfhŸshJ ?

	 m)	 bkŒahd	 M)	 inline
	 ï)	 F¿¥ò	 <)	 K‹Åašò

55.	 Ãfœ¤jiy, HTML toth¡fš brŒtj‰F nj®î 

brŒa nt©oaJ vJ ?

	 m)	 File → HTML	 M)	 File → Export
	 ï)	 View → HTML	 <)	 View → Export
56.	 K¥gÇkhz mirî¥ gl§fŸ v¤jid ÃiyfËš 

cUtik¡f¥gL»‹wd ?

	 m)	 2 (ïu©L)	 M)	 4 (eh‹F)

	 ï)	 5 (IªJ)	 <)	 3 (_‹W)

57.	 C++ - š ru§fis ïiz¡f, gad® vªj 

bra‰T¿id ga‹gL¤j nt©L« ? 

	 m)	 strcat( )	 M)	 strlen( )
	 ï)	 strcpy( )	 <)	 strcmp( )
58.	 C++ - š Ñœf©lt‰¿š vJ Äfî« vËikahd 

Ô®khÅ¥ò T‰W ? 

	 m)	 if		  	 M)	 while
	 ï)	 switch		  	 <)	 break
59.	 C++ bkhÊÆš ïd¡FGÉ‹ kh¿fŸ ï›thW 

miH¡f¥gL»‹wd : 

	 m)	 tÊKiwfŸ		  M)	 bghUŸfŸ

	 ï)	 kh¿ÈfŸ	 	 	 <)	 bra‰TWfŸ

60.	 Ãfœ¤JjÈš xU xÈ mšyJ xË¡fh£áia 

brUf vªj ïiz¥òfis nj®î brŒa 

nt©L« ?

	 m)	 Insert → Movie and Sound
	 M)	 �Insert → Pictures
	 ï)	� Insert → Special characters
	 <)	 �Insert → Sound and movie

61.	 bršngá _y« brŒâfis mD¥gî«, bgwî« 

ga‹gL« bk‹bghUŸ vJ ?

	 m) 	 Microwave Media Service
  	 M)	 Multimedia Media Service
	 ï)	 Multimedia Messaging System
	 <)	 Microwave Messaging System
62.	 ã‹tUtdt‰¿š vJ gšÿlf¡ TW ïšiy ?

	 m)	 juî¤js« 	 M)	 xÈ

	 ï)	 xË¡fh£áfŸ	 <)	 ciu

63.	 °lh® iu£lÇš %y® âiuÆš njh‹whÉ£lhš 

vªj bgh¤jhid mG¤j nt©L« ?

	 m)	 Tools → ruler
	 M)	 Edit → ruler
	 ï)	 Format → ruler
	 <)	 View → ruler
64.	 °lh® iu£lÇš ã‹tU« vªj¥ bgh¤jhid 

mG¤âdhš vG¤J¥ ãiH âU¤J« ciuahlš 

bg£oia bgwyh« ? 

	 m)	 F1			   M)	 F5
	 ï)	 F7			   <)	  F11
65.	 ° l h ®  f h š » š  Ñ œ f © l t ‰ ¿ š  v ª j ¥ 

gÂ¡F¿ fz¡»l¥ ga‹gL« thŒghLfis 

m£ltiz¤jhËš nr®¡f ga‹gL»wJ ?

	 m)	 Insert Applet  	
	 M)	 Insert Formula
	 ï)	 Insert OLE object 	
	 <)	 Insert floating frame
66.	 ã‹tUtdt‰WŸ vJ xU brh‰braÈ (Word 

processor) MF«.

	 m)	 °lh® M~ã° fhš¡

 	 M)	 °lh® M~ã° ng°

	 ï)	 °lh® M~ã° iu£l®

	 <)	 °lh® M~ã° ï«¥bu°

67.	 ng¢áid m¥gona ciutoÉš fojkhf 

kh‰W« gÂia brŒa ga‹gL« rhjd« : 

	 m) 	 ik¡nuhngh‹  	 M)	 o¡lhngh~‹

	 ï)	 »uhkngh‹	 <)	 bršngh‹

68.	 C++ -  š bra‰F¿fS¡F  TLjyhd 

bra‰gh£oid tiuaW¥gJ.

	 m) 	 kuòÇk«

	 M)	 bra‰TW gÂ ÄF¥ò

	 ï)	 bra‰F¿ gÂ ÄF¥ò	

	 <)	 bghUŸ

69.	 'Data' v‹w brhš ã‹tU« vªj brhšÈÈUªJ 

tªjJ ? 

	 m) 	 Datem	 M)	 Datum
	 ï)	 Record	 <)	 File
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70.	 C++ miH¥ò¡ T‰¿ÈUªJ braš T¿D¡F«, 

braš TWfËÈUªJ miH¥ò¡ T‰¿D¡F« 

ïilna juîfË‹ ghŒî¡F tÊ¤jl§fshf 

ïit mik»‹wd. 

	 m)	 bra‰T¿‹ bga®	 M)	 msòU¡fŸ

	 ï)	 kâ¥ò	 <)	 F¿¥ò

71.	 C++  - š vªj mQ»ašig¡ bfh©L 

m¿É¡f¥g£l cW¥òfis mnj ïd¡FGÉ‹ 

cW¥òfS«, e£ò¢ bra‰TWfŸ vd¥gL« áy 

áw¥ò bra‰TWfS« k£Lnk mQf Koí« ? 

	 m)	 private	 M)	 public
	 ï)	 protected	 <)	 static
72.	 °lh® ï«¥buÌš Media player r‹dš âiuia 

âw¡f vij¤ nj®î brŒa nt©L« ?

	 m)	 Insert → Media player
	 M)	 View → Media player
	 ï)	 Format → Media player
	 <)	 Tools → Media player
73.	 °lh® fhš¡ m£ltiz¡ nfh¥ãš xU 

E©ziwÆÈUªJ ï‹bdhU E©ziw 

tiu bjhl®¢áahf cŸs E©ziwfŸ 

ï›thW miH¡fyh«.

	 m)	 E©ziw	 M)	 gu¥ò

	 ï)	 E©ziw KftÇ	 <)	 E©ziw R£o

74.	 °lh® ï«¥buÌš Styles and Formatting Window 
it âw¡f vªj rhÉia nj®î brŒa nt©L«?

	 m)	 F5	 M)	 F7	 ï)	 F11	 <)	 F12
75.	 C++ -š x›bthU bghUŸ cUth¡f¥gL« 

nghJ« ïj‰F jÅ¤jÅ Ãidtf ïl« 

xJ¡f¥gLtâšiy ?

	 m)	 bghUŸfŸ		 	
	 M)	 cW¥ò¢ bra‰TWfŸ

	 ï)	 juî cW¥òfŸ

	 <)	 static cW¥òfŸ

gFâ - II
VnjD« ïUgJ Édh¡fS¡F k£L« XÇU 

th¡»a§fËš ÉilaË¡fî« :� 20 × 2 = 40
76.	 ciu gâ¥ã¤jš v‹whš v‹d? 

77.	 jiy¥ò, mo¡F¿¥ã‹ ga‹ ahJ ? 

78.	 Ä‹ m£ltiz¢ braÈ - tiuaW. 

79.	 F¿¥ò tiuf :

	 a) E©ziw 

	 b) E©ziw R£o

80.	 juî nkyh©ik mik¥ò v‹whš v‹d ? 

81.	 tof£o v‹whš v‹d ? mj‹ tiffis 
g£oaÈLf.

82.	 cU¡Fiy¤jš v‹whš v‹d? 

83.	 FW¡fš v‹whš v‹d ? mj‹ tiffis 
g£oaÈLf.

84.	 Custom animation v‹whš v‹d?

85.	 star impress-š ášYit v›thW kiw¥ghŒ ?

86.	 ciw bghâah¡f« v‹whš v‹d ? 

87.	 ÉšiyfŸ v‹whš v‹d? mj‹ tiffŸ 
ahit?

88.	 C++- š g©òz®¤âÆ‹ ÉisîfŸ ahit ?

89.	 kl¡F v‹whš v‹d?  C++ - š mj‹ tiffŸ 
ahit ?

90.	 C++ - š R£L kh¿fŸ v‹whš v‹d? 

91.	 bra‰TWfŸ v‹whš v‹d? C++-š mj‹ 
e‹ikfŸ ahJ? 

92.	 C++ -š write () bra‰TW - F¿¥ò tiuf. 

93.	 ÑœfhQ« C++ f£lis ãiH R£LtJ V‹ ? 
a) int a[5.5];
b) float num[A];

94.	 C++ bkhÊÆš v›thW ïd¡FG cW¥òfis 
mQFthŒ? vL¤J¡fh£L jUf.

95.	 Static juî cW¥òfis¥ g‰¿ F¿¥ò tiuf.

96.	 bra‰F¿ gÂÄF¥ã‹ VnjD« ïu©L 
ÉâKiwfŸ vGJf.

97.	 e f š  M ¡ »  v › É j k h d  N H š f Ë š  
ïa¡f¥gL« ? 

98.	 C++ bkhÊÆš mQ»ašò v‹whš v‹d ? 

99.	 fÂ¥bgh¿ juth¡f« v‹whš v‹d ?

100.	 "mu© cil¤jš' v‹whš v‹d?

	 gFâ - III
VnjD« VG Édh¡fS¡F k£L« ÉilaË¡fî« :

� [7 × 5 = 35]
101.	 °lh® iu£lÇš jhÅa§F rÇ brŒí« g£oaÈš 

v›thW xU brhšiy nr®¡fyh« ? 

102.	 °lh® iu£lÇš X® m£ltizÆš tÇirfŸ 

k‰W« beLtÇirfŸ v›thW nr®¥ghŒ ? 

103.	 °lh® fhš»š cŸs gy tifahd ïa¡»fis  

vL¤J¡fh£Ll‹ És¡Ff. 

104.	 rh®ò v‹whš v‹d ? mij v›thW xU 

m£ltiz¤ jhËš EiH¡fyh«?

105.	 i f t Ê ¢  b r a y h ¡ f  K i w Æ š  V ‰ g L « 

FiwghLfis ÉtÇ.

106.	 EiHî nrhâ¥ò kl¡FfŸ v‹whš v‹d? 

VnjD« xU kl¡»‹ f£lis mik¥ig 

vL¤J¡fh£Ll‹ ÉtÇ.

107.	 C++  bkhÊÆš F¿¥ò _y« miH¤jš 

KiwÆid vL¤J¡fh£Ll‹ ÉtÇ.

108.	 kuòÇk¤â‹ tiffis ÉtÇ.

109.	 bfhL¡f¥g£l btËpL bgWtj‰F Ñœ¡f©l 

C++ ÃuÈš fhQ« ãiHfis¤ âU¤â vGJf. 
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	 Output: 
Concatenated Strings...computer science

	 Program:
# include <iostream. h>
# include < conio.h >
# include < string.s >
class strings
{
	 Char s[12];
	 Public:
	 Strings()
	 {
		  S[0] = "\0";
	 }
string (char *c)
{
strcopy (s,c);
}
Char * operator - (strings x1)
{
char *temp;
strcopy(test,s);
strcat(temp,x1,s);
return temp;
}
};
void main[]
{
	 clearscr();
	 strings s1("test"), $2("science\0");
char * concatstr;
concatstr = s1 + s2;
cout>>"\n concatenated strings...">>concatstr;
}	

110. ã‹tU« C++ ÃuÈ‹ btËp£oid vGJf :
#include<iostream. h>
#include<conio.h>
class sum
{
	 int a, b, s;

	 public:
		  sum ( )
		  {
		    �cout<<"\n Non parameterized Constructor";
			   a = 14;
			   b = 5;
			   s = 0;

}
sum(int c, int d)
{
cout<<"\nConstructor with Parameters";	
a = c;
b = d;
s = 0;
}
void add( )
{
s = a + b;
}
void display( )
{
cout<<"\nThe Two numbers are ";
cout<<a<<'t'<<b;
cout<<"\nThe Sum = "<<s;
}

};
void main ( )
{
clrscr( );
sum x,y(5, 10);
x.add( );
y.add( );
cout<<"\n Object - 1";
x.display( );
cout<<"\n Object - 2";
y.display( );
}

]]]]
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ÉilfŸ

gFâ - I

	 1.	 (<);	 2.	 (m);	 3.	 (M);	 4.	 (ï);	 5.	 (m);	 6.	 (M);	 7.	 (ï);	 8.	 (<);	 9.	 (M);	10.	  (<);	

	 11.	 (M);	12.	 (m);	 13.	 (ï);	 14.	 (M);	15.	 (<);	 16.	 (<);	 17.	 (<);	 18.	 (m);	 19.	 (<);	 20.	  (M);	

	 21.	 (<);	 22.	 (ï);	 23.	 (ï);	 24.	 (<);	 25.	 (<);	 26.	 (m);	 27.	 (M);	28.	 (ï);	 29.	 (<);	 30.	  (<);	

	 31.	 (m);	 32.	 (m);	 33.	 (M);	34.	 (<);	 35.	 (m);	 36.	 (m);	 37.	 (m);	 38.	 (ï);	 39.	 (M);	40.	  (m);	

	 41.	 (ï);	 42.	 (ï);	 43.	 (M);	44.	 (ï);	 45.	 (m);	 46.	 (m);	 47.	 (ï);	 48.	 (ï);	 49.	 (m);	 50.	  (<);	

	 51.	 (M);	52.	 (m);	 53.	 (ï);	 54.	 (<);	 55.	 (M);	56.	 (<);	 57.	 (ï);	 58.	 (m);	 59.	 (M);	60.	  (m);	

	 61.	 (ï);	 62.	 (m);	 63.	 (<);	 64.	 (ï);	 65.	 (M);	66.	 (ï);	 67.	 (M);	68.	 (ï);	 69.	 (M);	70.	  (M);	

	 71.	 (m);	 72.	 (<);	 73.	 (M);	74.	 (ï);	 75.	 (M). 

gFâ - II

76.	 BYQj§p ×§RôL JÚ EûWûVf úNojRp 

ApXÕ HtL]úY Es[ EûW«p              

Uôt\eLû[f ùNnRp B¡V úYûXLÞdÏ 

EûW T§l©jRp (text editing) Guß ùTVo.

77.	 1. x›bthU g¡f¤âY« jÅ¤jÅahf 

j£l¢R brŒa nt©oaâ‰F¥ gâyhf 

j i y ¥ ò  m š y J  m o ¡ F ¿ ¥ ò f Ÿ 

cgnahf¥gL¤j¥gL»wJ.

	 2. £X TVàs[ Ï±l×Lû[ TdLj§u 

úUp KWj§Ûm ̧ r KWj§Ûm RÚYRtÏ 

RûXl× Utßm A¥dÏ±l×Ls 

ERÜ¡u\].

78.	 ª u  A h PY û Qf ù N V È  Gu TÕ 

L¦lùTô±«p, ùSÓY¬ûNLû[d ùLôiP 

AhPYûQ A±dûLLû[ EÚYôdLÜm, 

AYt±p úUtùLôiÓ LQd¸ÓLû[f 

ùNnVÜm TVuTÓm JÚ LQd¸hÓjRôs 

BÏm.

79.	 a) ÖiQû\: m£ltiz¢ braÈ 

t Ç i rf i sí « b eL t Ç i rf i sí « 

bfh©L mik¡f¥g£LŸsJ. tÇirfS« 

beLtÇirfS« FW¡»L« nghJ E©ziw 

(cell) fŸ cUth»‹wd.

	 b) ÖiQû\fÑh¥ :

	 ÖiQû\fÑh¥ GuTÕ ÖiQû\ûVf Ñt± 

T°fùNuß ùR¬Ùm JÚ ùNqYL Yû[Vm 

BÏm. AhPYûQd úLôl©p T¦ùNnVj 

ùRôPeÏmúTôÕ GlùTôÝÕúU ùRôPdLj§p 

ÖiQû\f Ñh¥ A1 Cp Rôu CÚdÏm,  

ÖiQû\fÑh¥«u CPjûR, ÑhùPÈûVd 

ùLôiÓ ApXÕ ®ûNl TXûL«p Es[ 

Am×l ùTôjRôuLû[d (arrow keys) ùLôiÓ 

Uôt\Xôm.

80.	 JÚ RWÜjR[ úUXôiûU AûUl× 

GuTÕ TX TV]ô[oLs RWÜjR[j§p 

Es[ RWÜLû[ ùT\úYô, úRûYùV²p 

Uôt\úYô ApXÕ G°V ApXÕ £dLXô] 

®]YpLû[ ùNVpTÓjÕYRtúLô 

úRûYlTÓm ̈ WpL°u ùRôÏlTôÏm.



SURA B
OOKS

8� RuhÉ‹  12 M« tF¥ò  fÂ¥bgh¿Æaš  2016 - #]‹ Édh¤jhŸ ÉilfSl‹

81.	 tof£lš (Filtering) : juî¤js§fËš, xU 

m£ltizÆÈUªJ nj®î brŒa¥g£l 

xU F¿¥ã£l g£oaš mšyJ xU gâÉ‹ 

áWgFâia k£L« gh®¡fnth mšyJ 

nknyho¤ njlnth, cUth¡f¥g£LŸs 

bra‰Tnw tof£lyhF«.

	 tof£lš ïu©L tif¥gL«. mitahtd

	 1.  AutoFilter

	 2. Standard Filter

82.	 EÚdÏûXjRp (Warping) GuTÕ JÚ 

¨ZtTPjûR §Új§ - EÚUôt± 

úYß JÚ ¨ZtTPUôL Uôtßm  

Øû\VôÏm. ùTÚmTôXô] CdLôX 

TpíPLl TVuTôÓLs, Ï±lTôL 

®û[VôhÓLs, CkRj ùRô̄ pÖhTeLû[ 

UôVj úRôt\ (Virtual  reality) 
ùRô̄ pÖhTjúRôÓ CûQjÕ, TôolúTôo 

Rôàm AkRf ãZÈu AeLUôL úYiÓm 

YûL«p EÚYûUdLlTÓ¡u\].

83.	 ÏßdLp GuTÕ, úLôl©p TXØû\ YÚm 

EÚdLû[ LiP±kÕ AYt±p Juû\ 

UhÓúU úRd¡ûYdÏm ùRô¯pÖhTUôÏm.

	 ÏßdLÈu YûLLs :

	 i. CZl×ûPd ÏßdLm	

	 ii. CZl©Xô ÏßdLm

84. 	Custom Animation :

	 ïªj¥g¡f«, ášYÉš tH§F« bghUŸfS¡F 

mirî¥gl Éisîfis nr®¡fnth, kh‰¿ 

mik¡fnth cjî»wJ.

85.		 (i)    �£pÛdLôh£«ÈÚkÕ Uû\dL ®Úm×m 

£pÛûYjúRoÜ ùNnV úYiÓm.

	 (ii)	 Slide Show → Show / Hide Slide 
CûQl×Lû[j úRoÜ ùNnV 

úYiÓm.

	 úRoÜ ùNnR £pÛ Gi ¿dLlTÓm.  

B]ôp AkR £pÛ ¨Lrf£j 

ùRôÏl©ÈÚkÕ ¿dLlTP®pûX 

GuTûRd LÚj§p ùLôs[ úYiÓm.

86.	 RWÜLû[Ùm ùNVtáßLû[Ùm JÚ 

ùTôÚs YûWVû\dÏs Ju\ôLl 

©ûQjÕûYdÏm ùNVpÖhTm Eû\

ùTô§VôdLm G]lTÓ¡\Õ.

87.	 A¥lTûP C]eLs JhÓùUôjRUôL ®pûXLs (Tokens) G]lTÓ¡u\]. ®pûX 

GuTÕ JÚ ¨WÈp Es[ Áf£ß R²jR AXÏ BÏm.

F¿¥bga®fŸ áw¥ò¢
brh‰fŸ

kh¿ÈfŸ bra‰F¿fŸ ÃW¤j‰F¿fŸ 

ÉšiyfË‹ tif¥ghLfŸ

ÉšiyfŸ
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88.	 Ti×Qoj§L°u ®û[ÜLs :

	 (i)    �unsigned Guàm Ti×Qoj§, úSoUm/

G§oUm GuTûRd Ï±dÏm Ï± 

©hûPÙm U§l×QojRl TVuTÓj§d 

ùLôsYRôp Uô± HtÏm U§l©u 

YWmùTpûX Uôt±VûUdLlTÓ¡\Õ.

	 (ii)	 long Gußm Ti×Qoj§ Ï±l©hP 

RW®]j§u ûThÓLû[ A§L¬jÕ, 

U§l©u YWmùTpûXûV ¿h¥d¡\Õ.

89.	 UPdÏLs, JÚ LhPû[j ùRôÏ§ûV 

Ï±l©hP RPûYLs §ÚmTj §ÚmT 

¨û\úYtß¡u\].

	 £++ ùUô¯«p, êuß YûLVô] UPdÏLs 

Es[]. AûYVôY],

	 (i) for ( ) UPdÏ, (ii) while ( ) UPdÏ,  

(iii) do. while ( ) UPdÏ.

90.	 ÑhÓ GuTÕ JÚ ¨û]YL ØLY¬ûV 

HtÏm Uô± BÏm. JÚ Uô±«u  

¨û]YL CÚl©PjûR úSW¥VôL 

AÔÏYRtÏ ÑhÓLs ERÜ¡u\].

91.	 bra‰TWfŸ : á++ ÃušfË‹ f£lik¥ò¡ 

TWfshf¤ âfœgit bra‰TWfŸ MF«.

	 e‹ikfŸ :

	 (i)    �̈ Wp Ï±Øû\«u UßTV]ôdLm.

	 (ii)	 JÚ ùNVtá±û] R²VôL 

¨WpùTVojÕ (Compiling) ûYjÕd 

ùLôiPôp JußdÏ úUtThP ̈ WpLs 

ARû]l T¡okÕùLôiÓ TVuùT\ 

Ø¥Ùm.

92.	� write ( ) GuTÕ A¥lTûP ùY°ÂhÓj 

RôûW ARôYÕ ostream-u Eßl×f 

ùNVtá\ôÏm. Ko C]dÏÝ®u  

Aû]jÕ Eßl×f ùNVtáßLû[Ùm, 

AkR C]dÏÝ®p EÚYôdLlThP Ko 

C]lùTôÚ°u (object/instance) êXUôL 

AÔL úYiÓm. write () ùNVtá±àdÏj 

úRûYVô] CWiÓ A[×ÚdLs NWj§u 

ùTVo, LôhPlTP úYi¥V GÝjÕL°u 

Gi¦dûL B¡VûY BÏm.

93.	 (a) int a[5.5];

	 A¦«u T¬UôQm ØÝGiQôLúY 

CÚdLúYiÓm.

	 (b) float num |A| : 

	 A¦«u T¬UôQm ùY°lTûPVôL 

A±®dLlTP úYiÓm. C§p, A Guàm 

Uô±dÏ U§l× GÕÜm ¡ûPVôÕ. 

	 Cdátû\úV,

	 float num[‘A’] ApXÕ,

	 const A = 10; float num [A];

	 G] Uôt± GÝRXôm.

94.	 ïd¡FGÉ‹ cW¥òfis¥ òŸË¢ bra‰F¿ 

_y« mQf Koí«. vL¤J¡fh£lhf, student 
ïd¡FGÉ‹ execute() bra‰T¿id 

miH¡F« T‰W ï›thW mikí«.

	

stud.execute( );

cW¥ò¢ bra‰TW

òŸË¢ bra‰F¿

bghUË‹ bga®

95.	 (i)    �static RWÜ Eßl× C]dÏÝ®p ØRp 

ùTôÚs EÚYôdLlTÓmúTôÕ, 0 Gu\ 

ùRôPdL U§lûTl ùTßm. ARu©\Ï 

ùRôPdL U§l©ÚjRlTÓY§pûX.

	 (ii)	 ¨û]YLj§p, Eßl× Uô±dÏ 

JúWùVôÚ SLp UhÓúU CÚdÏm 

(ùTôÕ CPj§u JÚ TÏ§VôL). AúR 

C]dÏÝ®u ©\ ùTôÚsLÞm  

¨û]YLj§Ûs[ AkRùYôÚ 

SLûXúV T¡okÕùLôs¡u\].
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	 (iii)	 ARu YûWùVpûXÙm AÔ¡Vp×m 

AkR C]d ÏÝÜdÏsú[Rôu.  

B]ôp ARu YôrSôs, ¨Wp 

ùNVpThÓ Ø¥ÙmYûW CÚdÏm.

96.	 (i)	� HtùL]úY CÚdÏm ùNVtÏ±LÞdÏ 

UhÓúU T¦ªÏdL Ø¥Ùm. ×§V 

ùNVtÏ±Lû[ EÚYôdL Ø¥VôÕ.

	 (ii)	� T¦ªÏdLlThP ùNVtÏ± Ht¡u\ 

ùNVúXt©LÞs Juß UhÓUôYÕ 

TV]o YûWVßjR RW®]UôL CÚdL 

úYiÓm.

97.	 SLp Bd¡ ¸rLôÔm ãZpL°p 

CVdLlTÓ¡\Õ :

	 (i)	� HúRàm Ko Eßl×f 

ùNVtá±àdÏ JÚ ùTôÚû[ 

A[×ÚYôL Aàl© 

ûYdÏmúTôÕ.

	 (ii)	� Ko Eßl×f ùNVtáß JÚ 

ùTôÚû[j §Úl©Vàl×múTôÕ.

	 (iii)	� JÚ ùTôÚs Ï±l×YûL 

A[×ÚYôL Bd¡dÏ Aàl© 

ûYdLlTÓmúTôÕ.

98.	 UW×¬Uj§p Ï±l©PjRdL áß  

Gu]ùY²p, RÚ®dLlThP C]

dÏÝ®u ùTôÚsLÞm Eßl×LÞm 

A¥lTûP C]dÏÝ®u Eßl×Lû[ 

GlúTôÕ, GlT¥l TVuTÓj§d ùLôs[ 

úYiÓm GuTÕRôu. CÕúY, AÔ¡Vp× 

(accessibility) G]lTÓ¡\Õ.

99.	 L¦lùTô±j RWYôdLm GuTÕ ©\ 

Y¥YeL°p Es[ RLYpLû[d 

L¦lùTô±«p ûLVôsYRtúLt\ 

RLYXôn Uôt±VûUlTRôÏm. YûWTPeLs, 

ûLùVÝjÕ, ¨LrTPeLs, JÈ B¡V 

TpúYß Y¥YeL°p Es[ RLYpLû[d 

L¦lùTô±j RLYXôdL Ø¥¡\Õ.

100.	 NhPl×\mTô] Øû\«p JÚ L¦lùTô± 

Øû\ûU«p ApXÕ ©ûQVj§p 

ÖûZYûRúV AWi EûPjRp  

Gu¡ú\ôm. L¦lùTô±«p CÚdÏm 

£\lTô] Y[eLû[f NhPl×\mTôLl 

TVuTÓjÕYúR AWi EûPjRÈu 

A¥lTûP úSôdLm BÏm. Y[eLs 

GuTûY YuùTôÚs, ùUuùTôÚs, 

úLôl×Ls, Øû\ûUj RLYpLs - CYtßs 

GÕYôLÜm CÚdLXôm. T¯YôeLp, Y¦Ll 

úTôh¥, NôLNm B¡VûY CjRûLV Ït\

jÕdLô] ©\ LôWQeLs BÏm.

gFâ - III

101.	 £X YôojûRLû[ ùS°úLôh¥]ôp 

A¥dúLô¥ÓYÕ UhÓUpXôUp, vPôo 

B@©v ûWhPo Rô]ôLúY £X GÝjÕl 

©ûZLû[f N¬ ùNnÙm. ERôWQUôL “teh” 
Guß JÚ ùNôpûXj Rô]ôLúY “the” 
Guß Uôt±d ùLôsÞm. CqYôß vPôo 

B@©v ûWhPo Rô]ôLúY ©ûZ §ÚjÕm 

ùNôtL°u Th¥VúXôÓ úYß ùNôtLû[Ùm 

úNojÕd ùLôs[Xôm. GÓjÕdLôhPôL 

JÚ TV]o Colour Gu\ ùNôpûX 

A¥dL¥ Color Guß RY\ôLj RhPfÑ  

ùNnYôú\Vô]ôp Rô²VeÏ N¬ ùNnÙm 

úRo®p CkRf ùNôpûXf úNojÕd 

ùLôs[Xôm. ARu ©u]o JqùYôÚ Øû\ 

Color Guß N¬Vô] ùNôp Uôt±«PlTÓm.

	 Rô²VeÏ N¬ ùNnÙm (Auto Correct) 
Th¥VÈp JÚ ùNôpûXf úNojRp :

	 JÚ RY\ô] ùNôpÛm ARtÏf N¬Vô] 

ùNôpûXÙm Rô²VeÏ N¬ ùNnÙm 

Th¥VÈp úNolTRtLô] Y¯Øû\Ls 

©uYÚUôß :

	 Tools → Auto Correct → Auto Format Gu\ 

LhPû[ûVj úRoÜ ùNnV úYiÓm.
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	 Auto Correct EûWVôPp ùTh¥ úRôußm. 

CkRl ùTh¥«p Replace Gu\ ùRôÏ§ûVj 

úRoÜ ùNnVúYiÓm. ClùTôÝÕ Replace 
Gu\ ùSÓY¬ûN«p Uôt±«PlTP 

úYi¥V  ùNôpûXÙm with Gu\ 

ùSÓY¬ûN«p Uôtßf ùNôpûXÙm RhPfÑ 

ùNnV úYiÓm. ©u OK ùTôjRôû]d 

¡°d ùNnV úYiÓm..

	 CRu ©u]o Replace ùSÓY¬ûN«p Es[ 

ùNôpûXj RhPfÑ ùNnRôp vPôo B@©v 

ûWhPo Rô]ôLúY With Gu\ ùSÓY¬ûN«p 

Es[ ùNôpûXd ùLôiÓ Uôt±«Óm.

102.	 JÚ G°V AhPYûQûVf ùNnRp :

	 AhPYûQ«p ùSÓY¬ûNûVf úNolTRtÏ 

¸rLiP Y¯Øû\Lû[d ûLVô[ úYiÓm.

	 (i)	�    Gu\ T¦dÏ±ûV ¡°d ùNnRôp 

ùNÚÏm CPm Es[ Y¬ûNdÏ ̧ ZôL 

JÚ Y¬ûN úNodLlTÓm.

	 (ii)	�   Gu\ T¦dÏ±ûV ¡°d 

ùNnRôp ùNÚÏm CPm Es[ 

ùSÓY¬ûNdÏ YXÕ TdLUôL JÚ 

ùSÓY¬ûN úNodLlTÓm.

	 J u ß d Ï  ú U t T h P  Y ¬ û N 

ApXÕ  ù SÓY¬ûVf  ú N o d L  

®Úm©]ôp Table → Insert → Rows ApXÕ  

(Table → Insert → Columns) Gu\ LhPû[ûVl 

TVuTÓjR JÚ EûWVôPp ùTh¥ úRôußm. 

C§p ùSÓY¬ûN«u Gi¦dûLûVd 

ù L ôÓ d L  úYiÓm .  ©u  OK  

ùTôjRôû]d ¡°d ùNnRôp úRûYVô] 

ùSÓY¬ûN AhPYûQ«p úNodLlTÓm.

103.	 (i) Gi L¦R CVd¡Ls (Arithmetic 
Operators) :

	 ¸rLiP CVd¡Ls ®ûPLû[ GiL[ôL 

ùLôÓdÏm.

CVd¡Ls ùTVo GÓjÕdLôhÓ

 + (plus) Addition 1+1
– (minus) Subtraction 2–1
– (Minus) Negation –5
* (asterisk) Multiplication 2*2
 / (Slash) Division 9/3

% (Percent) Percent 15%
^ (Caret) Exponentiation 3^2

   (ii) JlÀhÓ (Comparative) CVd¡Ls :

	 EiûU (True) ApXÕ ùTôn (False) Gu\ 

RLYûXd ùLôÓdÏm CkR CVd¡Ls.

CVd¡Ls ùTVo GÓjÕdLôhÓ

= Equal A1=B1
> Greater than A1>B1
< Less than A1<B1

> = Greater than or 
equal to

A1>=B1

< = Less than or 
equal to

A1<=B1

< > Inequality A1< >B1

      (iii) EûW (Text) CVd¡Ls :

	 EûWlTÏ§Lû[ Ju\ôL CûQdL 

ERÜ¡u\Õ CkR CVd¡Ls.

CVd¡Ls ùTVo GÓjÕdLôhÓ

& (AND) EûW CVd¡

(Text Operator)
“Star” & “Office” 
Guß ùLôÓjRôp

“StarOffice” Guß 

YÚm.

      (iv) TôoûY«Ó (Reference) CVd¡Ls :

	 JÚ ØLY¬ÆÈÚkÕ Cuù]ôÚ ØLY¬ 

YûWl TW®Ùs[ ÖiQû\Ls  

Aû]jûRÙm L¦lÀh¥tÏ Es[ôdL 

CkR CVd¡Ls TVuTÓ¡u\].
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CVd¡Ls ùTVo GÓjÕdLôhÓ

: (Colon) TWl× (Range) A1 : C 108

(A1 ØRp C 
108 YûW Es[ 

ÖiQû\Lû[d 

Ï±dÏm)
! (Exclamation) Ïßd¸Ó 

(Intersection)
SUM (A1 : B6 ! 
B5 : C12)

	 Gi L¦R CVd¡Lû[ YônTôÓL°p 

TVuTÓjÕmúTôÕ LQd¡VÈp 

TVuTÓjRlTÓm AúR Y¬ûN 

Øû\«pRôu (StarCalc)-Ûm L¦lÀÓLs 

ùNnVlTÓ¡u\]. L¦lÀhÓ Y¬ûN Øû\ 

¸rLiPYôß AûUÙm :

	 (1) §\u ̂  (Exponentiation)

	 (2) G§o¨ûXVôdLp (Negative)

	 (3) ùTÚdLp & YÏjRp (*, /)

	 (4) áhPp & L¯jRp (+, –).

104.	 StarCalc-Cp TXYûLVô] Nôo×Ls (Functions) 
Es[]. Nôo×Ls GuT] Øu]RôLúY 

YûWVßdLlThP YônTôÓLs BÏm. CkR 

Nôo×Ls, StarCalc-Cp Es[ Function Wizard 
Guàm Nu]p §ûW«p (Windows) Es[ 

CÝTh¥ Th¥VÈp (Pull-Down Menu) Es[].

	 CkR Nôo×Ls TX YûLL[ôLl 

©¬dLlThÓs[]. CkR YûLLs 

YûL«ÝlTh¥ Th¥VÈp (Category Pull 
-Down Menu) ùLôÓdLlThÓs[].

	 JÚ NôoûTj úRokùRÓdL Insert  gh¥dÏs 

ùNuß Function Th¥ûVj úRoÜ ùNnV 

úYiÓm. EPú] Function Wizard EûWVôPp 

ùTh¥ úRôußm. A§p Category ùTh¥ûVj 

úRoÜ ùNnÕ All Gu\ Th¥ûV ‘¡°d’ 

ùNnRôp Function ùTh¥«p GpXô Nôo×LÞm 

úRôußm. JÚ Ï±l©hP YûLûVj 

úRokùRÓjRôp, AkR YûLûVf NôokR 

ùRôPoTô] Nôo×Ls UhÓm Th¥VÈPlThÓ 

LôhPlTÓm.

	 JÚ Ï±l©hP NôoûTj úRoÜ ùNnV, 

Category ùTh¥«p AkR Nôo©u YûLûVj 

úRoÜ ùNnV úYiÓm. ©\Ï úRûYVô] 

NôoûTd LiÓ©¥dL, CÝ Th¥ûV EÚ[f 

ùNnV úYiÓm.

	 ©\Ï úRûYVô] NôoûTl Tt±V ®YWm 

A±V AkR Nôo©u ÁÕ Ñh¥ûV ûYjÕ 

JÚ Øû\ ‘¡°d’ ùNnV úYiÓm. CkR 

NôoûT AhPYûQd úLôl©p ùT\ 

CÚØû\ ‘¡°d’ ùNnV úYiÓm.

	 f(x) CkR Function Wizard T¦dÏ±ûVl (lcon) 
TVuTÓj§Ùm Nôo×Lû[j úRoÜ ùNnÕ 

AhPYûQ«p ùT\ Ø¥Ùm.

	 GÓjÕdLôhPôL, SQRT Gu\ NôoûT 

(JÚ Gi¦u YodL êXjûR (Square 
root) L¦dÏm Nôo×) AhPYûQd 

úLôl©p JÚ ÖiQû\«p GÝR  

úYiÓUô]ôp ¸rLiP Y¯Øû\ûVl 

©uTt\ úYiÓm : GkR ÖiQû\«p 

SQRT Gu\ NôoûT GÝR úYiÓúUô 

AkR ÖiQû\ûVj úRoÜ ùNnÕ Function 
AutoPilot Gu\ T¦dÏ± (Icon)ûV ‘¡°d’ 
ùNnV úYiÓm. ©\Ï Category ùTh¥«p 

Mathematical Gu\ YûLûVj úRoÜ ùNnV 

úYiÓm. ClùTôÝÕ CÝTh¥ûV  

(Pull-Down Menu) EÚ[f ùNnÕ SQRT Gu\ 

NôoûTj úRoÜ ùNnÕ CÚØû\ ‘¡°d’ 
ùNnV úYiÓm. EPú] AutoPilot Nôo× JÚ 

£ß ®[dLjûR Lôh¥, GiûQ Es°Pj 

çiÓm. AlùTôÝÕ GkR Gi¦u 
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YodL êXjûRd LiÓ©¥dL úYiÓúUô 

AkR GiûQ (CeÏ 64 Gu\ GiûQ)d 

ùLôÓdL úYiÓm. ©\Ï OK Gu\ Th¥ûV 

‘¡°d’ ùNnV úYiÓm. EPú] SQRT 

Nôo× 64 Gu\ Gi¦u YodLêXjûRd 

LiÓ©¥jÕ 8 Gu\ GiûQ ®ûPVôL 

ÖiQû\«p LôhPlTÓm. 

105.	ûLY¯jRWÜf ùNVXôdL Øû\«p 

Es[ £X Ïû\TôÓLs ¸úZ ùLôÓdLl-

ThÓs[] :

	 (i)	� ûLY¯f ùNVXôdLl T¦ûV 

úUtùLôsÞmúTôÕ ùNnûL«u 

§\àm ÕpÈVØm CRû]f ùNnÙm 

R²U²R¬u §\ûUûVl ùTôßjúR 

AûU¡u\Õ.

	 (ii)	� ûLY¯f ùNVXôdLl T¦ûV 

úUtùLôiPôp T¦ûV Ø¥dL 

ªÏkR úSWm BÏm.

	 (iii)	�ùTôÕYôL U²RoLs, AYoL[ôL 

ùNVpTÓmúTôÕ L¦lÀhÓl 

©ûZLÞm (Computational), úSôdÏ 

UVdLl©ûZLÞm (Parallax Errors) 

CûZlTÕ CVp×.

	 (iv)	�SôúU ClT¦«p ûLY¯f ùNVXôdL 

Øû\«p DÓTÓmúTôÕ JqùYôÚ 

LhPj§Ûm RôsLû[ ªÏ§VôL 

TVuTÓjR úYi¥«ÚdÏm. CR]ôp 

Sôm TôÕLôlTôL ûYj§ÚdL úYi¥V 

RôsLÞm úLôl×LÞm ùTÚ¡, 

AûY JÚ ùTÚm Ï®VXô¡®Óm.

	 (v)	� RWÜLû[j §ÚjÕRp, UôtßRp, 

¿dÏRp úTôu\ ùNVtTôÓLs 

ûLY¯jRWÜf ùNVXôdLj§p ùTÚm 

úNôoûYÙm R[of£ûVÙm RÚm.

106.	for ( ) UPdÏ JÚ ÖûZÜd LhÓlTôhÓ 

UPdÏ. JÚ ùNVpTôhûPd Ï±l©hP 

RPûYLs ¨û\úYtßYRtÏ CÕ 

TVuTÓ¡\Õ. CRu LhPû[ AûUl× :

	 for (ùRôPdL U§l×; úNô§l× ¨TkRû]; 

ªÏl×)

		 {

			  ùNVpTôhÓj ùRôÏ§;

	 } 

		 for (;;) UPdÏl ùTôÕYôL ©uYÚUôß 

ùNVpTÓm :

	 (i)	�  WÈu LhÓlTôÓ ØRuØRÈp 

U P d ¡ ² p  Ö û Z Ù m ú T ô Õ , 

LhÓlTôhÓ Uô±«p ùRôPdL U§l× 

CÚjRlTÓm.

	 (ii)	� T kRû] T¬úN ô§ dLl TÓm , 

¨TkRû] ‘N¬’ G²p, UPd¡u 

EPtTÏ§ ùNVpTÓjRlTÓm. CRu 

LôWQUôLúY CkR UPdÏ ‘ÖûZÜd 

LhÓlTôhÓ UPdÏ’ G]lTÓ¡\Õ.

	 (iii)	�U P d¡u  EP t TÏ§  ÁiÓ m 

¨û\úYt\lTÓYRtÏ ØuTôLd 

LhÓlT ôhÓ U ô±«u U§l× 

ªÏdLlThÓ, ÁiÓm ¨TkRû] 

T¬úNô§dLlTÓm.

	 (iv)	� TkRû] ‘RYß’ G] BÏmúTôÕ 

UPdÏ Ø¥ÜdÏ YÚm.

	 ¸úZÙs[ GÓjÕdLôhÓ for (;;) UPd¡u 

ùNVpTôhûP ®[dÏm :



SURA B
OOKS

14� RuhÉ‹  12 M« tF¥ò  fÂ¥bgh¿Æaš  2016 - #]‹ Édh¤jhŸ ÉilfSl‹

 # include <iostream.h>

 for (i = 1;  i < 6;  i ++)

ªÏjRp (ØRp TÏ§)

T¬úNô§l× ¨TkRû] 

(2-Bm TÏ§)

LhÓlTôhÓ Uô±«p ùRôPdL 

U§l©ÚjRp (3-Bm TÏ§)

(i)	 L hÓ l T ôhÓ  U ô±«p ù R ôPdL 

U§l©ÚjRp , UPd¡u EPtTÏ§ 

ØRuØRÈp ùNVpTÓjRlTÓYRtÏ 

ØuT ôL ,  Jú W  JÚØû \  R ôu 

ùNVpTÓjRlTÓm.

(ii)	 UPd¡u EPtTÏ§ JqùYôÚØû\ 

ùNVpTÓjRlTÓYRtÏ ØuTôLÜm 

¨TkRû] T¬úNô§dLlTÓm.

(iii)	¨TkRû] T¬úNô§dLlTÓYRtÏ 

ØuTôLd LhÓlTôhÓ Uô±«u U§l× 

ªÏdLlTÓm.

107.	Ï±l× êXm AûZdÏm ùNVtáß : 

Ï±l× êXm AûZjRp Øû\«p, 

A û Z d L l T Ó m  ù N V t á ± u 

ùNVÛÚ×Ls - Øû\Vô] A[×ÚdLs 

- AûZdÏm ùNVtá±Ûs[ ùUnVô] 

A[×ÚdL°u Uôtßl ùTVoL[ôLf (alias) 

ùNVpTÓ¡u\]. ùNVtáß R]Õ ùNôkRf 

ùNVÛÚ×L°u ÁÕ ùNVpTÓmúTôÕ 

EiûU«p, êXj RWÜL°u ÁúR 

ùNVpTÓ¡\Õ GuTÕ CRu ùTôÚ[ôÏm. 

Ï±l×YûL A[×ÚdLû[l TVuTÓj§, 

swap ( ) ùNVtá±û]j §Új§ GÝÕúYôm.

// To exchange values

# include <iostream.h>

#include <conio.h>

void swap (int &n1, int &n2)

{

	 int temp;

	 temp = n1;

	 n1 = n2;

	 n2 = temp;

	 cout<<‘\n’<< n1 <<‘\t’<<n2<<‘\n’;

}

void main ( )

{

	 int m1 = 10, m2 = 20;

	 clrscr( );

	 cout<<“\nValues before swap call” << ‘\t’ << m1 

<< ‘\t’ << m2;

	 swap(m1,m2);

	 cout<<“\n Calling swap..”;

	 cout<<“\n Back to main.... Values are” << ‘\t’ << 

m1 << ‘\t’<< m2;

	 getch ( );

}

ùY°ÂÓ :

	 Values before swap call	 10	 20

	 Calling swap …..		  20	 10

	 Back to main…… Values are	 20	 10  	
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	 Øû\Vô] A[×ÚdL°p ùNnR  

Uôt\eLs ùUnVô] A[×ÚdL°p 

©W§TÈjÕs[]. LôWQm, Øû\Vô] 

A[×ÚdLs Ï±l×YûL GuTRôp 

AûY ùUnVô] A[×ÚdL°u  

¨û]YL CPeLû[úV ÑhÓ¡u\].

108.	�RÚ®dLlThP  C]dÏÝdLû[ 

A¥lTûPVôLd  ùL ôiÓ ×§V 

C]dÏÝdLû[j RÚ®dL Ø¥Ùm. 

U W × ¬Uj§p  TXYûL  Es[] . 

AûYVôY], (i) JÚY¯ UW×¬Um, (ii) 

TXY¯ UW×¬Um, (iii) TX¨ûX UW×¬Um, 

(iv) LXl× UW×¬Um, (v) T¥Øû\ 

UW×¬Um B¡VûY BÏm.

	 (i) �JÚY¯ UW×¬Um (Single Inheritance). 

J ú W ù V ô Ú  C ] d Ï Ý û Y 

A ¥ l T û P V ô L d  ù L ô i Ó 

RÚ®dLl ThP  C]dÏÝûY 

EÚYôdÏYÕ JÚY¯ UW×¬Um 

BÏm.

		

RÚ®dLlThP C]dÏÝ 

- úUXô[o

A¥lTûP C]dÏÝ 

- T¦Vôs

	 (ii) �TXY¯ U W×¬Um  (Multiple 

Inheritance) . JußdÏ úUtThP 

C]dÏÝdL°ÈÚkÕ RÚ®dLlThP 

C]dÏÝûY EÚYôdÏYÕ TXY¯ 

UW×¬Um BÏm.

	

RÚ®dLlThP C]dÏÝ: 

- úUXô[o

A¥lTûP C]dÏÝ: 

ØLY¬

A¥lTûP C]dÏÝ: 

AÛYXLm

	 (iii) �TX¨ûX UW×¬Um (Multilevel 
Inheritance) . RÚ®dLlThP Ko 

C]dÏÝûY A¥lTûPVôLd 

ùLôiÓ Cuù]ôÚ RÚ®dLlThP 

C]dÏÝûY EÚYôdÏYÕ TX¨ûX 

UW×¬Um BÏm.

	

109.	  Output:

	 Concatenated Strings...computer science
	 Program:

#include <iostream.h>
#include < conio.h >
#include < string.h >
class strings
{
	 char S[12]
	 public
	 strings( )
	 {
		  S[0] = "\0";
	 }

RÚ®dLlThP C]dÏÝ: 

RkûR

RÚ®dLlThP C]dÏÝ: 

ÏZkûR

A¥lTûP C]dÏÝ: 

RôjRô
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string (char *c)
{
strcpy (s,c)
}
char * operator - (strings x1)
{
char *temp;
strcpy(test,s);
strcat(temp,x1,s);
return temp;
}
};
void main( )
{
	 clrscr( );
	 strings s1("test"), s2("science\0");

char * concatstr;
concatstr = s1 + s2;
cout<<"\n concatenated strings...">>concatstr;
}

110.	  Output:

	 Non Parameterized Constructor

	 Constructor with Parameters

	 Object - 1

	 The Two numbers are 5   6

	 The Sum = 11

	 Object - 2

	 The Two numbers are 15    10

	 The Sum = 15

]]]]




